mt-check.cgiはシステムの構成を確認し、Movable Typeを実行するために必要なコンポーネントがそろっていることを確認するためのスクリプトです。

システム情報

確認中: 必須モジュール

CGI::Cookie

サーバーに CGI::Cookie がインストールされています(バージョン 1.29)。

File::Spec (version >= 0.8)

サーバーに File::Spec がインストールされています(バージョン 3.27)。

Image::Size

サーバーに Image::Size がインストールされています(バージョン 3.2)。

CGI

サーバーに CGI がインストールされています(バージョン 3.48)。

確認中: データストレージモジュール

これらのモジュールは、Movable Type がデータを保存するために必要なモジュールです。DBIと、1つ以上のデータベース用のモジュールをインストールする必要があります。

DBI (version >= 1.21)

サーバーに DBI がインストールされています(バージョン 1.52)。

DBD::mysql

サーバーに DBD::mysql がインストールされています(バージョン 3.0007)。

DBD::SQLite

サーバーに DBD::SQLite がインストールされています(バージョン 1.14)。

DBD::Pg (version >= 1.32)

サーバーに DBD::Pg がインストールされています(バージョン 1.49)。

DBD::SQLite2

SQLite(v2)データベースを使うにはDBD::SQLite2のデータベースドライバが必要です。

サーバーに DBD::SQLite2か、DBD::SQLite2の動作に必要な他のモジュールがインストールされていません。 DBD::SQLite2のインストールはインストールマニュアルに沿って行ってください。 詳細

確認中: オプションモジュール

これらのモジュールのインストールは任意です。お使いのサーバーにこれらのモジュールがインストールされていない場合でも、Movable Type の基本機能は動作します。これらのモジュールの機能が必要となった場合にはインストールを行ってください。

Scalar::Util

サーバーに Scalar::Util がインストールされています(バージョン 1.19)。

Crypt::DSA

コメント投稿時のサインインが高速になります。

サーバーに Crypt::DSAか、Crypt::DSAの動作に必要な他のモジュールがインストールされていません。 Crypt::DSAのインストールはインストールマニュアルに沿って行ってください。 詳細

XML::SAX

サーバーに XML::SAX がインストールされています(バージョン 0.96)。

IPC::Run

MTのイメージドライバとしてNetPBMを利用する場合に必要となります。

サーバーに IPC::Runか、IPC::Runの動作に必要な他のモジュールがインストールされていません。 IPC::Runのインストールはインストールマニュアルに沿って行ってください。 詳細

Archive::Zip

バックアップと復元で圧縮の機能を利用する場合に必要となります。

サーバーに Archive::Zipか、Archive::Zipの動作に必要な他のモジュールがインストールされていません。 Archive::Zipのインストールはインストールマニュアルに沿って行ってください。 詳細

Storable

サーバーに Storable がインストールされています(バージョン 2.15)。

SOAP::Lite (version >= 0.5)

XML-RPC による作業を行う場合に必要となります。

SOAP::Liteがインストールされていないか、インストールされているバージョンが古い、または SOAP::Liteの動作に必要な他のモジュールが見つかりません。 SOAP::Liteのインストールはインストールマニュアルに沿って行ってください。 詳細

List::Util

サーバーに List::Util がインストールされています(バージョン 1.19)。

Cache::Memcached

キャッシング機能としてmemcachedを利用する場合に必要となります。

サーバーに Cache::Memcachedか、Cache::Memcachedの動作に必要な他のモジュールがインストールされていません。 Cache::Memcachedのインストールはインストールマニュアルに沿って行ってください。 詳細

HTML::Entities

サーバーに HTML::Entities がインストールされています(バージョン 1.35)。

Cache::File

Yahoo! Japanによるコメント投稿者のOpenID認証を許可する場合に必要となります。

サーバーに Cache::Fileか、Cache::Fileの動作に必要な他のモジュールがインストールされていません。 Cache::Fileのインストールはインストールマニュアルに沿って行ってください。 詳細

Digest::MD5

サーバーに Digest::MD5 がインストールされています(バージョン 2.36)。

Text::Balanced

サーバーに Text::Balanced がインストールされています(バージョン 1.95)。

Crypt::SSLeay

Crypt::SSLeayはAOLやYahoo!などのSSLを利用するOpenIDのコメント投稿者を認証するために必要となります。

サーバーに Crypt::SSLeayか、Crypt::SSLeayの動作に必要な他のモジュールがインストールされていません。 Crypt::SSLeayのインストールはインストールマニュアルに沿って行ってください。 詳細

GD

サーバーに GD がインストールされています(バージョン 2.35)。

Archive::Tar

サーバーに Archive::Tar がインストールされています(バージョン 1.38)。

Safe

サーバーに Safe がインストールされています(バージョン 2.12)。

XML::Parser

アクションストリームを利用するために必要です。

サーバーに XML::Parserか、XML::Parserの動作に必要な他のモジュールがインストールされていません。 XML::Parserのインストールはインストールマニュアルに沿って行ってください。 詳細

IO::Uncompress::Gunzip

サーバーに IO::Uncompress::Gunzip がインストールされています(バージョン 2.008)。

Digest::SHA1

サーバーに Digest::SHA1 がインストールされています(バージョン 2.11)。

Imager

アップロードした画像のサムネイルを作成する場合に必要となります。

サーバーに Imagerか、Imagerの動作に必要な他のモジュールがインストールされていません。 Imagerのインストールはインストールマニュアルに沿って行ってください。 詳細

IO::Compress::Gzip

サーバーに IO::Compress::Gzip がインストールされています(バージョン 2.008)。

XML::Atom

Atom APIを利用する場合に必要となります。

サーバーに XML::Atomか、XML::Atomの動作に必要な他のモジュールがインストールされていません。 XML::Atomのインストールはインストールマニュアルに沿って行ってください。 詳細

Image::Magick

サーバーに Image::Magick がインストールされています(バージョン 6.3.7)。

LWP::UserAgent

サーバーに LWP::UserAgent がインストールされています(バージョン 5.834)。

MIME::Base64

サーバーに MIME::Base64 がインストールされています(バージョン 3.07)。

Mail::Sendmail

SMTPサーバーを経由してメールを送信する場合に必要になります。

サーバーに Mail::Sendmailか、Mail::Sendmailの動作に必要な他のモジュールがインストールされていません。 Mail::Sendmailのインストールはインストールマニュアルに沿って行ってください。
【Sendmailはインストール済みですが、このシステムチェックプログラムからは検出出来ませんでした。】 詳細

HTML::Parser

サーバーに HTML::Parser がインストールされています(バージョン 3.55)。

File::Temp

サーバーに File::Temp がインストールされています(バージョン 0.22)。

システムのチェックを完了しました。

Movable Typeを利用できます。 お使いのサーバーには、Movable Type の動作に必要なすべてのモジュールがインストールされています。モジュールを追加インストール作業は必要はありません。マニュアルに従い、インストールを続けてください。